Help » General Questions » What system requirements do I need to view Dleex materials?

What system requirements do I need to view Dleex materials?

In order to view Dleex materials, please make sure that you comply with the following system requirements:
  • Firefox 1.1 or later, Internet Explorer 5.0 or later, Safari 1.0 or later
  • 128k Broadband internet connection or faster



You may also be interested in:



Dleex

© 2007–2017 Dleex.

English      German      French      Russian

For any question please write to our email e-mail